Filestack用の公式Python SDK「filestack-python」のインストール

Filestack用の公式Python SDK「filestack-python」のインストールについて解説しています。

「filestack-python(https://github.com/filestack/filestack-python)」は、APIおよびコンテンツ管理システムにより、強力なファイルアップロード及び変換機能をWeb、またはモバイルアプリに追加することができます。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■filestack-pythonをインストールする

filestack-pythonをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install filestack-python

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、pipを使う場合にはコマンドでの切り替えを行います。

py -3.8 -m pip install filestack-python

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting filestack-python
Downloading filestack_python-3.5.0-py3-none-any.whl (34 kB)
Collecting trafaret==2.0.2
Downloading trafaret-2.0.2-py3-none-any.whl (27 kB)
Collecting requests>=2.25.1
Using cached requests-2.27.1-py2.py3-none-any.whl (63 kB)
Requirement already satisfied: charset-normalizer~=2.0.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from requests>=2.25.1->filestack-python) (2.0.12)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\user_\appdata\roaming\python\python38\site-packages (from requests>=2.25.1->filestack-python) (2021.5.30)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from requests>=2.25.1->filestack-python) (1.25.11)
Requirement already satisfied: idna<4,>=2.5 in c:\users\user_\appdata\roaming\python\python38\site-packages (from requests>=2.25.1->filestack-python) (2.10)
Installing collected packages: trafaret, requests, filestack-python
Attempting uninstall: requests
Found existing installation: requests 2.24.0
Uninstalling requests-2.24.0:
Successfully uninstalled requests-2.24.0
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
web3 5.24.0 requires jsonschema<4.0.0,>=3.2.0, but you have jsonschema 4.4.0 which is incompatible.
web3 5.24.0 requires websockets<10,>=9.1, but you have websockets 10.2 which is incompatible.
tensorboard 2.5.0 requires google-auth-oauthlib<0.5,>=0.4.1, but you have google-auth-oauthlib 0.5.1 which is incompatible.
streamlit 0.82.0 requires click<8.0,>=7.0, but you have click 8.0.4 which is incompatible.
spacy 3.2.0 requires pydantic!=1.8,!=1.8.1,<1.9.0,>=1.7.4, but you have pydantic 1.9.0 which is incompatible.
pyfcm 1.5.3 requires urllib3>=1.26.0, but you have urllib3 1.25.11 which is incompatible.
notion-py 0.0.10 requires requests==2.24.0, but you have requests 2.27.1 which is incompatible.
mega-py 1.0.8 requires tenacity<6.0.0,>=5.1.5, but you have tenacity 8.0.1 which is incompatible.
firebase-admin 5.0.1 requires google-api-core[grpc]<2.0.0dev,>=1.22.1; platform_python_implementation != "PyPy", but you have google-api-core 2.7.1 which is incompatible.
Successfully installed filestack-python-3.5.0 requests-2.27.1 trafaret-2.0.2

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、filestack-pythonが正常にインストールされたことになります。今回は「ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed.」といったエラーが表示されているので、このような場合は、仮想環境を構築して、インストールした方が良い。

なお、今回はfilestack-pythonのバージョン3.5.0をインストールしました。

コメント

タイトルとURLをコピーしました