Pythonオブジェクトを使ってSQLデータベースを操作する「SQLModel」をインストールする

Pythonオブジェクトを使ってSQLデータベースを操作するライブラリ「SQLModel」のインストールについて解説しています。

SQLModel(https://github.com/tiangolo/sqlmodel)は、コードからPythonオブジェクトを使ってSQLデータベースを操作することができます。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■SQLModelをインストールする

SQLModelをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install sqlmodel

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、pipを使う場合にはコマンドでの切り替えを行います。

py -3.8 -m pip install sqlmodel

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting sqlmodel
Downloading sqlmodel-0.0.4-py3-none-any.whl (21 kB)
Collecting SQLAlchemy<1.5.0,>=1.4.17
Downloading SQLAlchemy-1.4.28-cp38-cp38-win_amd64.whl (1.5 MB)
|████████████████████████████████| 1.5 MB 1.3 MB/s
Collecting sqlalchemy2-stubs
Downloading sqlalchemy2_stubs-0.0.2a19-py3-none-any.whl (190 kB)
|████████████████████████████████| 190 kB 6.8 MB/s
Requirement already satisfied: pydantic<2.0.0,>=1.8.2 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sqlmodel) (1.8.2)
Requirement already satisfied: typing-extensions>=3.7.4.3 in c:\users\user_\appdata\roaming\python\python38\site-packages (from pydantic<2.0.0,>=1.8.2->sqlmodel) (3.7.4.3)
Requirement already satisfied: greenlet!=0.4.17 in c:\users\user_\appdata\roaming\python\python38\site-packages (from SQLAlchemy<1.5.0,>=1.4.17->sqlmodel) (1.1.2)
Installing collected packages: sqlalchemy2-stubs, SQLAlchemy, sqlmodel
Successfully installed SQLAlchemy-1.4.28 sqlalchemy2-stubs-0.0.2a19 sqlmodel-0.0.4

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、sqlmodelが正常にインストールされたことになります。

なお、今回はsqlmodelのバージョン0.0.4をインストールしました。

コメント

タイトルとURLをコピーしました