Webサービスを開発するためのマイクロフレームワーク「klein」のインストール

Pythonを使用してWebサービスを開発するためのマイクロフレームワーク「klein」のインストールについて解説しています。

「klein(https://github.com/twisted/klein,https://klein.readthedocs.io/en/latest/index.html)」は、Webサービスを開発するためのマイクロフレームワークで、BottleやFlaskといったフレームワークと似た小さなAPIを持っています。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■kleinをインストールする

kleinをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install klein

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、バージョンの切り替えを行います。

py -3.8 -m pip install klein

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting klein
Downloading klein-21.8.0-py2.py3-none-any.whl (88 kB)
|████████████████████████████████| 88 kB 736 kB/s
Requirement already satisfied: incremental in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (21.3.0)
Requirement already satisfied: hyperlink in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (21.0.0)
Collecting Tubes
Downloading Tubes-0.2.0-py2.py3-none-any.whl (58 kB)
|████████████████████████████████| 58 kB 3.8 MB/s
Requirement already satisfied: zope.interface in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (5.4.0)
Requirement already satisfied: attrs in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (21.2.0)
Requirement already satisfied: Twisted>=16.6 in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (22.2.0)
Requirement already satisfied: Werkzeug in c:\users\user_\appdata\roaming\python\python38\site-packages (from klein) (2.0.1)
Requirement already satisfied: constantly>=15.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from Twisted>=16.6->klein) (15.1.0)
Requirement already satisfied: Automat>=0.8.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from Twisted>=16.6->klein) (20.2.0)
Requirement already satisfied: twisted-iocpsupport<2,>=1.0.2 in c:\users\user_\appdata\roaming\python\python38\site-packages (from Twisted>=16.6->klein) (1.0.2)
Requirement already satisfied: typing-extensions>=3.6.5 in c:\users\user_\appdata\roaming\python\python38\site-packages (from Twisted>=16.6->klein) (3.7.4.3)
Requirement already satisfied: idna>=2.5 in c:\users\user_\appdata\roaming\python\python38\site-packages (from hyperlink->klein) (2.10)
Requirement already satisfied: setuptools in c:\users\user_\appdata\roaming\python\python38\site-packages (from zope.interface->klein) (59.6.0)
Requirement already satisfied: six in c:\users\user_\appdata\roaming\python\python38\site-packages (from Tubes->klein) (1.15.0)
Collecting characteristic
Downloading characteristic-14.3.0-py2.py3-none-any.whl (15 kB)
Installing collected packages: characteristic, Tubes, klein
Successfully installed Tubes-0.2.0 characteristic-14.3.0 klein-21.8.0

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、kleinが正常にインストールされたことになります。

なお、今回はkleinのバージョン21.8.0をインストールしました。

コメント

タイトルとURLをコピーしました