Unicodeに関する文字化けや破損の問題を修正する「ftfy」のインストール

Unicodeに関する文字化けや破損の問題を修正する「ftfy」のインストールについて解説しています。

「ftfy(https://pypi.org/project/ftfy/,https://ftfy.readthedocs.io/en/latest/)」は、さまざまな方法で壊れているUnicodeを修正することのできるPythonライブラリです。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■ftfyをインストールする

ftfyをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install ftfy

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、バージョンの切り替えを行います。

py -3.8 -m pip install ftfy

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting ftfy
Downloading ftfy-6.1.1-py3-none-any.whl (53 kB)
---------------------------------------- 53.1/53.1 kB 542.5 kB/s eta 0:00:00
Requirement already satisfied: wcwidth>=0.2.5 in c:\users\user_\appdata\roaming\python\python38\site-packages (from ftfy) (0.2.5)
Installing collected packages: ftfy
Successfully installed ftfy-6.1.1

Enterキーを押すと、インストールが開始され、「Successfully installed」と表示されます。これが表示されれば、ftfyが正常にインストールされたことになります。

なお、今回はftfyのバージョン6.1.1をインストールしました。

コメント

タイトルとURLをコピーしました