テキストデータ(感情分析、分類、翻訳など)を処理するため「textblob」のインストール

テキストデータ(感情分析、分類、翻訳など)を処理するためのPythonライブラリ「textblob」のインストールについて解説しています。

「textblob(https://github.com/sloria/TextBlob)」は、名詞句の抽出、品詞のタグ付け、単語とフレーズの頻度、分類などの処理を行うことができます。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■textblobをインストールする

textblobをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install textblob

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、バージョンの切り替えを行います。

py -3.8 -m pip install textblob

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting textblob
Downloading textblob-0.17.1-py2.py3-none-any.whl (636 kB)
|████████████████████████████████| 636 kB 939 kB/s
Requirement already satisfied: nltk>=3.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from textblob) (3.6.5)
Requirement already satisfied: tqdm in c:\users\user_\appdata\roaming\python\python38\site-packages (from nltk>=3.1->textblob) (4.60.0)
Requirement already satisfied: regex>=2021.8.3 in c:\users\user_\appdata\roaming\python\python38\site-packages (from nltk>=3.1->textblob) (2021.11.10)
Requirement already satisfied: joblib in c:\users\user_\appdata\roaming\python\python38\site-packages (from nltk>=3.1->textblob) (1.0.1)
Requirement already satisfied: click in c:\users\user_\appdata\roaming\python\python38\site-packages (from nltk>=3.1->textblob) (8.0.4)
Requirement already satisfied: colorama in c:\users\user_\appdata\roaming\python\python38\site-packages (from click->nltk>=3.1->textblob) (0.4.4)
Installing collected packages: textblob
Successfully installed textblob-0.17.1

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、textblobが正常にインストールされたことになります。

今回は、textblobのバージョン0.17.1をインストールしました。

コメント

タイトルとURLをコピーしました