【データ分析】データセットを視覚化して比較する「sweetviz」をインストールする

データセットを視覚化して比較するPythonの「sweetviz」ライブラリのインストールについて解説しています。

sweetviz(https://github.com/fbdesignpro/sweetviz)は、短いコードで、データセット、ターゲット値、または関連付けを視覚化し比較することができます。データ分析する際には重宝します。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■sweetvizをインストールする

sweetvizをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install sweetviz

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、pipを使う場合にはコマンドでの切り替えを行います。

py -3.8 -m pip install sweetviz

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting sweetviz
  Downloading sweetviz-2.1.3-py3-none-any.whl (15.1 MB)
     |████████████████████████████████| 15.1 MB 6.4 MB/s
Requirement already satisfied: matplotlib>=3.1.3 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (3.4.2)
Requirement already satisfied: tqdm>=4.43.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (4.60.0)
Requirement already satisfied: pandas!=1.0.0,!=1.0.1,!=1.0.2,>=0.25.3 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (1.2.4)
Requirement already satisfied: numpy>=1.16.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (1.20.3)
Requirement already satisfied: scipy>=1.3.2 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (1.7.0)
Requirement already satisfied: jinja2>=2.11.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from sweetviz) (3.0.1)
Collecting importlib-resources>=1.2.0
  Downloading importlib_resources-5.4.0-py3-none-any.whl (28 kB)
Collecting zipp>=3.1.0
  Using cached zipp-3.6.0-py3-none-any.whl (5.3 kB)
Requirement already satisfied: MarkupSafe>=2.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from jinja2>=2.11.1->sweetviz) (2.0.1)
Requirement already satisfied: python-dateutil>=2.7 in c:\users\user_\appdata\roaming\python\python38\site-packages (from matplotlib>=3.1.3->sweetviz) (2.8.1)
Requirement already satisfied: cycler>=0.10 in c:\users\user_\appdata\roaming\python\python38\site-packages (from matplotlib>=3.1.3->sweetviz) (0.10.0)
Requirement already satisfied: pillow>=6.2.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from matplotlib>=3.1.3->sweetviz) (8.2.0)
Requirement already satisfied: kiwisolver>=1.0.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from matplotlib>=3.1.3->sweetviz) (1.3.1)
Requirement already satisfied: pyparsing>=2.2.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from matplotlib>=3.1.3->sweetviz) (2.4.7)
Requirement already satisfied: pytz>=2017.3 in c:\users\user_\appdata\roaming\python\python38\site-packages (from pandas!=1.0.0,!=1.0.1,!=1.0.2,>=0.25.3->sweetviz) (2021.1)
Requirement already satisfied: six in c:\users\user_\appdata\roaming\python\python38\site-packages (from cycler>=0.10->matplotlib>=3.1.3->sweetviz) (1.15.0)
Installing collected packages: zipp, importlib-resources, sweetviz
Successfully installed importlib-resources-5.4.0 sweetviz-2.1.3 zipp-3.6.0

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、sweetvizが正常にインストールされたことになります。

なお、今回はsweetvizのバージョン2.1.3をインストールしました。

コメント

タイトルとURLをコピーしました