Web自動化、エンドツーエンドテストPythonフレームワーク「SeleniumBase」のインストール

Web自動化、エンドツーエンドテストPythonフレームワーク「SeleniumBase」のインストールについて解説しています。

「SeleniumBase(https://github.com/seleniumbase/SeleniumBase)」は、Python開発者向けのWeb自動化エコシステム。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■seleniumbaseをインストールする

seleniumbaseをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install seleniumbase

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、バージョンの切り替えを行います。

py -3.8 -m pip install seleniumbase

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting seleniumbase
Downloading seleniumbase-3.1.0-py2.py3-none-any.whl (464 kB)
|████████████████████████████████| 464 kB 939 kB/s
Collecting matplotlib-inline==0.1.3
Using cached matplotlib_inline-0.1.3-py3-none-any.whl (8.2 kB)
Collecting attrs>=21.4.0
Using cached attrs-21.4.0-py2.py3-none-any.whl (60 kB)
Collecting ipdb==0.13.9
Downloading ipdb-0.13.9.tar.gz (16 kB)
Preparing metadata (setup.py) ... done
Requirement already satisfied: parse==1.19.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (1.19.0)
Collecting sortedcontainers==2.4.0
Using cached sortedcontainers-2.4.0-py2.py3-none-any.whl (29 kB)
Collecting boto==2.49.0
Downloading boto-2.49.0-py2.py3-none-any.whl (1.4 MB)
|████████████████████████████████| 1.4 MB 3.3 MB/s
Collecting trio==0.20.0
Downloading trio-0.20.0-py3-none-any.whl (359 kB)
|████████████████████████████████| 359 kB 3.3 MB/s
Collecting packaging>=21.3
Using cached packaging-21.3-py3-none-any.whl (40 kB)
Collecting pymysql==1.0.2
Downloading PyMySQL-1.0.2-py3-none-any.whl (43 kB)
|████████████████████████████████| 43 kB 736 kB/s
Collecting wsproto==1.1.0
Downloading wsproto-1.1.0-py3-none-any.whl (24 kB)
Collecting execnet==1.9.0
Downloading execnet-1.9.0-py2.py3-none-any.whl (39 kB)
Collecting py==1.11.0
Downloading py-1.11.0-py2.py3-none-any.whl (98 kB)
|████████████████████████████████| 98 kB 2.6 MB/s
Collecting rich==12.4.1
Downloading rich-12.4.1-py3-none-any.whl (231 kB)
|████████████████████████████████| 231 kB 6.4 MB/s
Collecting typing-extensions==4.0.0
Downloading typing_extensions-4.0.0-py3-none-any.whl (22 kB)
Collecting pytest-ordering==0.6
Downloading pytest_ordering-0.6-py3-none-any.whl (4.6 kB)
Collecting pytest==7.1.2
Downloading pytest-7.1.2-py3-none-any.whl (297 kB)
|████████████████████████████████| 297 kB 3.2 MB/s
Collecting six==1.16.0
Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Collecting soupsieve==2.3.2.post1
Downloading soupsieve-2.3.2.post1-py3-none-any.whl (37 kB)
Collecting pycparser==2.21
Using cached pycparser-2.21-py2.py3-none-any.whl (118 kB)
Collecting Pillow==9.1.1
Downloading Pillow-9.1.1-cp38-cp38-win_amd64.whl (3.3 MB)
|████████████████████████████████| 3.3 MB 2.2 MB/s
Collecting ipython==7.33.0
Downloading ipython-7.33.0-py3-none-any.whl (793 kB)
|████████████████████████████████| 793 kB 3.2 MB/s
Collecting more-itertools==8.13.0
Downloading more_itertools-8.13.0-py3-none-any.whl (51 kB)
|████████████████████████████████| 51 kB 161 kB/s
Collecting filelock>=3.7.0
Downloading filelock-3.7.0-py3-none-any.whl (10 kB)
Requirement already satisfied: urllib3==1.26.9 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (1.26.9)
Collecting pyotp==2.6.0
Downloading pyotp-2.6.0-py2.py3-none-any.whl (11 kB)
Collecting jedi==0.18.1
Using cached jedi-0.18.1-py2.py3-none-any.whl (1.6 MB)
Collecting traitlets>=5.2.1.post0
Downloading traitlets-5.2.1.post0-py3-none-any.whl (106 kB)
|████████████████████████████████| 106 kB 6.4 MB/s
Collecting trio-websocket==0.9.2
Using cached trio_websocket-0.9.2-py3-none-any.whl (16 kB)
Collecting pytest-forked==1.4.0
Downloading pytest_forked-1.4.0-py3-none-any.whl (4.9 kB)
Collecting sbvirtualdisplay==1.1.0
Downloading sbvirtualdisplay-1.1.0-py2.py3-none-any.whl (13 kB)
Collecting tomli>=2.0.1
Downloading tomli-2.0.1-py3-none-any.whl (12 kB)
Collecting parameterized==0.8.1
Downloading parameterized-0.8.1-py2.py3-none-any.whl (26 kB)
Collecting pdfminer.six==20220319
Downloading pdfminer.six-20220319-py3-none-any.whl (5.6 MB)
|████████████████████████████████| 5.6 MB 6.4 MB/s
Collecting idna==3.3
Using cached idna-3.3-py3-none-any.whl (61 kB)
Collecting prompt-toolkit==3.0.29
Downloading prompt_toolkit-3.0.29-py3-none-any.whl (381 kB)
|████████████████████████████████| 381 kB 3.2 MB/s
Collecting parse-type==0.6.0
Downloading parse_type-0.6.0-py2.py3-none-any.whl (32 kB)
Requirement already satisfied: charset-normalizer==2.0.12 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (2.0.12)
Requirement already satisfied: tornado==6.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (6.1)
Requirement already satisfied: toml==0.10.2 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (0.10.2)
Collecting decorator==5.1.1
Using cached decorator-5.1.1-py3-none-any.whl (9.1 kB)
Collecting behave==1.2.6
Downloading behave-1.2.6-py2.py3-none-any.whl (136 kB)
|████████████████████████████████| 136 kB 3.3 MB/s
Requirement already satisfied: sniffio==1.2.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (1.2.0)
Collecting setuptools>=62.3.1
Downloading setuptools-62.3.1-py3-none-any.whl (1.2 MB)
|████████████████████████████████| 1.2 MB 3.2 MB/s
Collecting wheel>=0.37.1
Using cached wheel-0.37.1-py2.py3-none-any.whl (35 kB)
Collecting PyYAML>=6.0
Using cached PyYAML-6.0-cp38-cp38-win_amd64.whl (155 kB)
Collecting beautifulsoup4==4.11.1
Downloading beautifulsoup4-4.11.1-py3-none-any.whl (128 kB)
|████████████████████████████████| 128 kB 3.3 MB/s
Collecting fasteners==0.17.3
Downloading fasteners-0.17.3-py3-none-any.whl (18 kB)
Collecting h11==0.13.0
Using cached h11-0.13.0-py3-none-any.whl (58 kB)
Collecting cryptography==37.0.2
Downloading cryptography-37.0.2-cp36-abi3-win_amd64.whl (2.4 MB)
|████████████████████████████████| 2.4 MB 3.2 MB/s
Requirement already satisfied: cssselect==1.1.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (1.1.0)
Collecting certifi>=2021.10.8
Using cached certifi-2021.10.8-py2.py3-none-any.whl (149 kB)
Requirement already satisfied: pluggy==1.0.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (1.0.0)
Collecting chardet==4.0.0
Using cached chardet-4.0.0-py2.py3-none-any.whl (178 kB)
Collecting parso==0.8.3
Using cached parso-0.8.3-py2.py3-none-any.whl (100 kB)
Collecting pytest-html==2.0.1
Downloading pytest_html-2.0.1-py2.py3-none-any.whl (15 kB)
Requirement already satisfied: requests==2.27.1 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (2.27.1)
Collecting setuptools-scm>=6.4.2
Downloading setuptools_scm-6.4.2-py3-none-any.whl (37 kB)
Requirement already satisfied: colorama==0.4.4 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (0.4.4)
Collecting pytest-xdist==2.5.0
Downloading pytest_xdist-2.5.0-py3-none-any.whl (41 kB)
|████████████████████████████████| 41 kB 216 kB/s
Collecting pytest-metadata==2.0.1
Downloading pytest_metadata-2.0.1-py3-none-any.whl (9.9 kB)
Collecting pygments==2.12.0
Downloading Pygments-2.12.0-py3-none-any.whl (1.1 MB)
|████████████████████████████████| 1.1 MB 6.4 MB/s
Requirement already satisfied: pyopenssl==22.0.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from seleniumbase) (22.0.0)
Collecting cffi==1.15.0
Using cached cffi-1.15.0-cp38-cp38-win_amd64.whl (179 kB)
Collecting platformdirs>=2.5.2
Downloading platformdirs-2.5.2-py3-none-any.whl (14 kB)
Collecting selenium==4.1.5
Downloading selenium-4.1.5-py3-none-any.whl (979 kB)
|████████████████████████████████| 979 kB 6.8 MB/s
Collecting nose==1.3.7
Downloading nose-1.3.7-py3-none-any.whl (154 kB)
|████████████████████████████████| 154 kB 3.3 MB/s
Collecting pip>=22.1
Downloading pip-22.1-py3-none-any.whl (2.1 MB)
|████████████████████████████████| 2.1 MB 6.4 MB/s
Collecting pytest-rerunfailures==10.2
Downloading pytest_rerunfailures-10.2-py3-none-any.whl (11 kB)
Requirement already satisfied: pickleshare in c:\users\user_\appdata\roaming\python\python38\site-packages (from ipython==7.33.0->seleniumbase) (0.7.5)
Requirement already satisfied: backcall in c:\users\user_\appdata\roaming\python\python38\site-packages (from ipython==7.33.0->seleniumbase) (0.2.0)
Requirement already satisfied: wcwidth in c:\users\user_\appdata\roaming\python\python38\site-packages (from prompt-toolkit==3.0.29->seleniumbase) (0.2.5)
Requirement already satisfied: atomicwrites>=1.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from pytest==7.1.2->seleniumbase) (1.4.0)
Requirement already satisfied: iniconfig in c:\users\user_\appdata\roaming\python\python38\site-packages (from pytest==7.1.2->seleniumbase) (1.1.1)
Requirement already satisfied: commonmark<0.10.0,>=0.9.0 in c:\users\user_\appdata\roaming\python\python38\site-packages (from rich==12.4.1->seleniumbase) (0.9.1)
Collecting outcome
Using cached outcome-1.1.0-py2.py3-none-any.whl (9.7 kB)
Requirement already satisfied: async-generator>=1.9 in c:\users\user_\appdata\roaming\python\python38\site-packages (from trio==0.20.0->seleniumbase) (1.10)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in c:\users\user_\appdata\roaming\python\python38\site-packages (from packaging>=21.3->seleniumbase) (2.4.7)
Requirement already satisfied: PySocks!=1.5.7,<2.0,>=1.5.6 in c:\users\user_\appdata\roaming\python\python38\site-packages (from urllib3==1.26.9->seleniumbase) (1.7.1)
Building wheels for collected packages: ipdb
Building wheel for ipdb (setup.py) ... done
Created wheel for ipdb: filename=ipdb-0.13.9-py3-none-any.whl size=11648 sha256=c97933089047f39ee7b4a7cf70437fc33c2b1b53bdbf31e85b4b8c162d77fea2
Stored in directory: c:\users\user_\appdata\local\pip\cache\wheels\d8\51\8c\3dceedacfd0f743f3736b3840d08b6746b6259deea98207ba4
Successfully built ipdb
Installing collected packages: pycparser, cffi, attrs, traitlets, tomli, sortedcontainers, py, parso, packaging, outcome, idna, h11, cryptography, wsproto, trio, six, setuptools, pytest, pygments, prompt-toolkit, matplotlib-inline, jedi, decorator, certifi, typing-extensions, trio-websocket, soupsieve, pytest-metadata, pytest-forked, parse-type, ipython, execnet, chardet, wheel, setuptools-scm, selenium, sbvirtualdisplay, rich, PyYAML, pytest-xdist, pytest-rerunfailures, pytest-ordering, pytest-html, pyotp, pymysql, platformdirs, pip, Pillow, pdfminer.six, parameterized, nose, more-itertools, ipdb, filelock, fasteners, boto, behave, beautifulsoup4, seleniumbase
Attempting uninstall: pycparser
Found existing installation: pycparser 2.20
Uninstalling pycparser-2.20:
Successfully uninstalled pycparser-2.20
Attempting uninstall: cffi
Found existing installation: cffi 1.14.5
Uninstalling cffi-1.14.5:
Successfully uninstalled cffi-1.14.5
Attempting uninstall: attrs
Found existing installation: attrs 21.2.0
Uninstalling attrs-21.2.0:
Successfully uninstalled attrs-21.2.0
Attempting uninstall: traitlets
Found existing installation: traitlets 5.0.5
Uninstalling traitlets-5.0.5:
Successfully uninstalled traitlets-5.0.5
Attempting uninstall: sortedcontainers
Found existing installation: sortedcontainers 2.1.0
Uninstalling sortedcontainers-2.1.0:
Successfully uninstalled sortedcontainers-2.1.0
Attempting uninstall: py
Found existing installation: py 1.10.0
Uninstalling py-1.10.0:
Successfully uninstalled py-1.10.0
Attempting uninstall: parso
Found existing installation: parso 0.8.2
Uninstalling parso-0.8.2:
Successfully uninstalled parso-0.8.2
Attempting uninstall: packaging
Found existing installation: packaging 20.9
Uninstalling packaging-20.9:
Successfully uninstalled packaging-20.9
Attempting uninstall: idna
Found existing installation: idna 2.10
Uninstalling idna-2.10:
Successfully uninstalled idna-2.10
Attempting uninstall: h11
Found existing installation: h11 0.12.0
Uninstalling h11-0.12.0:
Successfully uninstalled h11-0.12.0
Attempting uninstall: cryptography
Found existing installation: cryptography 36.0.1
Uninstalling cryptography-36.0.1:
Successfully uninstalled cryptography-36.0.1
Attempting uninstall: wsproto
Found existing installation: wsproto 1.0.0
Uninstalling wsproto-1.0.0:
Successfully uninstalled wsproto-1.0.0
Attempting uninstall: six
Found existing installation: six 1.15.0
Uninstalling six-1.15.0:
Successfully uninstalled six-1.15.0
Attempting uninstall: setuptools
Found existing installation: setuptools 59.6.0
Uninstalling setuptools-59.6.0:
Successfully uninstalled setuptools-59.6.0
Attempting uninstall: pytest
Found existing installation: pytest 6.2.4
Uninstalling pytest-6.2.4:
Successfully uninstalled pytest-6.2.4
Attempting uninstall: pygments
Found existing installation: Pygments 2.10.0
Uninstalling Pygments-2.10.0:
Successfully uninstalled Pygments-2.10.0
Attempting uninstall: prompt-toolkit
Found existing installation: prompt-toolkit 3.0.18
Uninstalling prompt-toolkit-3.0.18:
Successfully uninstalled prompt-toolkit-3.0.18
Attempting uninstall: matplotlib-inline
Found existing installation: matplotlib-inline 0.1.2
Uninstalling matplotlib-inline-0.1.2:
Successfully uninstalled matplotlib-inline-0.1.2
Attempting uninstall: jedi
Found existing installation: jedi 0.18.0
Uninstalling jedi-0.18.0:
Successfully uninstalled jedi-0.18.0
Attempting uninstall: decorator
Found existing installation: decorator 5.0.9
Uninstalling decorator-5.0.9:
Successfully uninstalled decorator-5.0.9
Attempting uninstall: certifi
Found existing installation: certifi 2021.5.30
Uninstalling certifi-2021.5.30:
Successfully uninstalled certifi-2021.5.30
Attempting uninstall: typing-extensions
Found existing installation: typing-extensions 3.7.4.3
Uninstalling typing-extensions-3.7.4.3:
Successfully uninstalled typing-extensions-3.7.4.3
Attempting uninstall: soupsieve
Found existing installation: soupsieve 2.2.1
Uninstalling soupsieve-2.2.1:
Successfully uninstalled soupsieve-2.2.1
Attempting uninstall: pytest-metadata
Found existing installation: pytest-metadata 1.11.0
Uninstalling pytest-metadata-1.11.0:
Successfully uninstalled pytest-metadata-1.11.0
Attempting uninstall: ipython
Found existing installation: ipython 7.24.1
Uninstalling ipython-7.24.1:
Successfully uninstalled ipython-7.24.1
Attempting uninstall: chardet
Found existing installation: chardet 3.0.4
Uninstalling chardet-3.0.4:
Successfully uninstalled chardet-3.0.4
Attempting uninstall: wheel
Found existing installation: wheel 0.37.0
Uninstalling wheel-0.37.0:
Successfully uninstalled wheel-0.37.0
Attempting uninstall: selenium
Found existing installation: selenium 3.141.0
Uninstalling selenium-3.141.0:
Successfully uninstalled selenium-3.141.0
Attempting uninstall: PyYAML
Found existing installation: PyYAML 5.4.1
Uninstalling PyYAML-5.4.1:
Successfully uninstalled PyYAML-5.4.1
Attempting uninstall: pytest-html
Found existing installation: pytest-html 3.1.1
Uninstalling pytest-html-3.1.1:
Successfully uninstalled pytest-html-3.1.1
Attempting uninstall: platformdirs
Found existing installation: platformdirs 2.4.0
Uninstalling platformdirs-2.4.0:
Successfully uninstalled platformdirs-2.4.0
Attempting uninstall: pip
Found existing installation: pip 21.3.1
Uninstalling pip-21.3.1:
Successfully uninstalled pip-21.3.1
Attempting uninstall: Pillow
Found existing installation: Pillow 8.2.0
Uninstalling Pillow-8.2.0:
Successfully uninstalled Pillow-8.2.0
Attempting uninstall: more-itertools
Found existing installation: more-itertools 8.12.0
Uninstalling more-itertools-8.12.0:
Successfully uninstalled more-itertools-8.12.0
Attempting uninstall: filelock
Found existing installation: filelock 3.3.1
Uninstalling filelock-3.3.1:
Successfully uninstalled filelock-3.3.1
Attempting uninstall: beautifulsoup4
Found existing installation: beautifulsoup4 4.9.3
Uninstalling beautifulsoup4-4.9.3:
Successfully uninstalled beautifulsoup4-4.9.3
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
wagtail 2.14.1 requires beautifulsoup4<4.10,>=4.8, but you have beautifulsoup4 4.11.1 which is incompatible.
wagtail 2.14.1 requires Pillow<9.0.0,>=4.0.0, but you have pillow 9.1.1 which is incompatible.
thinc 8.0.13 requires pydantic!=1.8,!=1.8.1,<1.9.0,>=1.7.4, but you have pydantic 1.9.0 which is incompatible.
tensorflow 2.5.0 requires numpy~=1.19.2, but you have numpy 1.21.5 which is incompatible.
tensorflow 2.5.0 requires six~=1.15.0, but you have six 1.16.0 which is incompatible.
tensorflow 2.5.0 requires typing-extensions~=3.7.4, but you have typing-extensions 4.0.0 which is incompatible.
tensorboard 2.5.0 requires google-auth-oauthlib<0.5,>=0.4.1, but you have google-auth-oauthlib 0.5.1 which is incompatible.
sudachipy 0.5.4 requires sortedcontainers~=2.1.0, but you have sortedcontainers 2.4.0 which is incompatible.
streamlit 0.82.0 requires click<8.0,>=7.0, but you have click 8.0.4 which is incompatible.
spacy 3.2.0 requires pydantic!=1.8,!=1.8.1,<1.9.0,>=1.7.4, but you have pydantic 1.9.0 which is incompatible.
pygooglenews 0.1.2 requires dateparser<0.8.0,>=0.7.6, but you have dateparser 1.1.1 which is incompatible.
notion-py 0.0.10 requires requests==2.24.0, but you have requests 2.27.1 which is incompatible.
mega-py 1.0.8 requires tenacity<6.0.0,>=5.1.5, but you have tenacity 8.0.1 which is incompatible.
httpcore 0.14.7 requires h11<0.13,>=0.11, but you have h11 0.13.0 which is incompatible.
helium 3.0.7 requires selenium==3.141.0, but you have selenium 4.1.5 which is incompatible.
google-drive-ocr 0.2.1 requires attrs==21.2.0, but you have attrs 21.4.0 which is incompatible.
google-drive-ocr 0.2.1 requires google-api-python-client==2.9.0, but you have google-api-python-client 2.42.0 which is incompatible.
google-drive-ocr 0.2.1 requires google-auth-oauthlib==0.4.1, but you have google-auth-oauthlib 0.5.1 which is incompatible.
google-cloud-firestore 2.1.3 requires google-api-core[grpc]<2.0.0dev,>=1.22.2, but you have google-api-core 2.7.1 which is incompatible.
google-cloud-core 1.7.1 requires google-api-core<2.0.0dev,>=1.21.0, but you have google-api-core 2.7.1 which is incompatible.
firebase-admin 5.0.1 requires google-api-core[grpc]<2.0.0dev,>=1.22.1; platform_python_implementation != "PyPy", but you have google-api-core 2.7.1 which is incompatible.
fimage 0.1.6 requires Pillow<9.0.0,>=8.0.0, but you have pillow 9.1.1 which is incompatible.
easyocr 1.4.1 requires Pillow<8.3.0, but you have pillow 9.1.1 which is incompatible.
celery 5.2.3 requires setuptools<59.7.0,>=59.1.1, but you have setuptools 62.3.1 which is incompatible.
Successfully installed Pillow-9.1.1 PyYAML-6.0 attrs-21.4.0 beautifulsoup4-4.11.1 behave-1.2.6 boto-2.49.0 certifi-2021.10.8 cffi-1.15.0 chardet-4.0.0 cryptography-37.0.2 decorator-5.1.1 execnet-1.9.0 fasteners-0.17.3 filelock-3.7.0 h11-0.13.0 idna-3.3 ipdb-0.13.9 ipython-7.33.0 jedi-0.18.1 matplotlib-inline-0.1.3 more-itertools-8.13.0 nose-1.3.7 outcome-1.1.0 packaging-21.3 parameterized-0.8.1 parse-type-0.6.0 parso-0.8.3 pdfminer.six-20220319 pip-22.1 platformdirs-2.5.2 prompt-toolkit-3.0.29 py-1.11.0 pycparser-2.21 pygments-2.12.0 pymysql-1.0.2 pyotp-2.6.0 pytest-7.1.2 pytest-forked-1.4.0 pytest-html-2.0.1 pytest-metadata-2.0.1 pytest-ordering-0.6 pytest-rerunfailures-10.2 pytest-xdist-2.5.0 rich-12.4.1 sbvirtualdisplay-1.1.0 selenium-4.1.5 seleniumbase-3.1.0 setuptools-62.3.1 setuptools-scm-6.4.2 six-1.16.0 sortedcontainers-2.4.0 soupsieve-2.3.2.post1 tomli-2.0.1 traitlets-5.2.1.post0 trio-0.20.0 trio-websocket-0.9.2 typing-extensions-4.0.0 wheel-0.37.1 wsproto-1.1.0

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、seleniumbaseが正常にインストールされたことになります。しかし、今回は「ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.(ERROR: pip の依存性解決は現在インストールされているすべてのパッケージを考慮に入れていません。この挙動は以下のような依存関係の衝突の原因となっています。)」という依存関係の衝突が原因でエラーが出力されました。このようなエラーを解決するためには、仮想環境を構築し、その上でインストールされることを推奨する。

なお、今回はseleniumbaseのバージョン3.1.0をインストールしました。

コメント

タイトルとURLをコピーしました