Pythonでインタラクティブなアプリをすばやく構築できる「flet」のインストール

Pythonでインタラクティブなアプリをすばやく構築できる「flet」のインストールについて解説しています。

「flet(https://github.com/flet-dev/flet)」は、Pythonで、HTTP、HTML、CSS、JavaSscriptなどの予備知識がなくても、簡単にリアルタイムのWeb、モバイル、デスクトップアプリケーションを構築できるライブラリです。

■Python

今回のPythonのバージョンは、「3.8.5」を使用しています。(Windows10)(pythonランチャーでの確認)

■fletをインストールする

fletをインストールを行いますが、今回はpipを経由してインストールを行うので、まずWindowsのコマンドプロンプトを起動します。

pip install flet

起動後、上記のコマンドを入力し、Enterキーを押します。

なお、今回は、pythonランチャーを使用しており、Python Version 3.8.5にインストールを行うために、pipを使う場合にはコマンドでの切り替えを行います。

py -3.8 -m pip install flet

切り替えるために、上記のコマンドを入力し、Enterキーを押します。

Defaulting to user installation because normal site-packages is not writeable
Collecting flet
Downloading flet-0.1.29-py3-none-win_amd64.whl (18.3 MB)
---------------------------------------- 18.3/18.3 MB 5.3 MB/s eta 0:00:00
Collecting beartype>=0.9.1
Downloading beartype-0.10.4-py3-none-any.whl (578 kB)
---------------------------------------- 578.1/578.1 kB 9.2 MB/s eta 0:00:00
Collecting websocket-client>=1.2.1
Downloading websocket_client-1.3.2-py3-none-any.whl (54 kB)
---------------------------------------- 54.3/54.3 kB 2.8 MB/s eta 0:00:00
Installing collected packages: websocket-client, beartype, flet
Attempting uninstall: websocket-client
Found existing installation: websocket-client 1.1.0
Uninstalling websocket-client-1.1.0:
Successfully uninstalled websocket-client-1.1.0
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
ibm-watson 5.2.2 requires websocket-client==1.1.0, but you have websocket-client 1.3.2 which is incompatible.
Successfully installed beartype-0.10.4 flet-0.1.29 websocket-client-1.3.2

Enterキーを押すと、インストールが開始され、上記のように「Successfully installed」と表示されます。これが表示されれば、fletが正常にインストールされたことになります。

しかし、今回は「ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.(pip の依存性解決は現在インストールされているすべてのパッケージを考慮に入れていません。この挙動は以下のような依存関係の衝突の原因となっています。)」というエラーが出力されてしまいました。依存関係の衝突が原因となっていますので、仮想環境を構築し、インストールすることを推奨します。

なお、今回はfletのバージョン0.1.29をインストールしました。

コメント

タイトルとURLをコピーしました